# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\$[a-zA-Z0-9._+%]+\}"
test_str = ("Obsahová symbolika\n\n"
"{$nadpish21} - nadpis h1 - h6, 1 - 128\n"
"{$htmltext21} - html text 1 - 128\n"
"{$plaintext1} - čistý text 1 - 128\n"
"{$arturl} - url daného konkrétního článku\n"
"{$pageurl1} - url vybraného článku, 1 - 128")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.