package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` 'cKey\d+' # search for cKey followed by a digit
.+? # match everything lazily
(\"|') # up to a single/double quote (capture this)
(?P<string>.*?) # match everything that is not a single / double quote
\1 # followed by the previously captured group`)
var str = `$data = array(
'cKey1' => "dsfaasdfasdfasdfasdf",
'cKey2' => "asdfasdfasdfadsfasdf",
'cKey3' => "dsfaasdfasdfasd'fasdf",
'cKey4' => "",
);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}