# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
'cKey\d+' # search for cKey followed by a digit
.+? # match everything lazily
(\"|') # up to a single/double quote (capture this)
(?P<string>.*?) # match everything that is not a single / double quote
\1 # followed by the previously captured group
"""
test_str = ("$data = array(\n"
" 'cKey1' => \"dsfaasdfasdfasdfasdf\",\n"
" 'cKey2' => \"asdfasdfasdfadsfasdf\",\n"
" 'cKey3' => \"dsfaasdfasdfasd'fasdf\",\n"
" 'cKey4' => \"\",\n"
");")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.