// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x) 'cKey\d+' # search for cKey followed by a digit
.+? # match everything lazily
(\"|') # up to a single/double quote (capture this)
(?P<string>.*?) # match everything that is not a single / double quote
\1 # followed by the previously captured group"#).unwrap();
let string = "$data = array(
'cKey1' => \"dsfaasdfasdfasdfasdf\",
'cKey2' => \"asdfasdfasdfadsfasdf\",
'cKey3' => \"dsfaasdfasdfasd'fasdf\",
'cKey4' => \"\",
);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}