re = / 'cKey\d+' # search for cKey followed by a digit
.+? # match everything lazily
(\"|') # up to a single\/double quote (capture this)
(?P<string>.*?) # match everything that is not a single \/ double quote
\1 # followed by the previously captured group/x
str = '$data = array(
\'cKey1\' => "dsfaasdfasdfasdfasdf",
\'cKey2\' => "asdfasdfasdfadsfasdf",
\'cKey3\' => "dsfaasdfasdfasd\'fasdf",
\'cKey4\' => "",
);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end