#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<quoted>(?<=,"|^")(?:""|[\w\W]*?)*(?=",|"$))|(?<normal>(?<=,(?!")|^(?!"))[^,]*?(?=(?<!")$|(?<!"),))|(?<eol>\r\n|\n)"
Local $sString = "normal,cell,contents" & @CRLF & _
"cell,"with" & @CRLF & _
"newline",in it" & @CRLF & _
"cell,"with ""quoted"" text",in it" & @CRLF & _
"cell,with "internal" quotes,in it" & @CRLF & _
"single quote,"""",cell" & @CRLF & _
"in cell,"quotes ""followed"", by",comma"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")