$re = '/(?<quoted>(?<=,"|^")(?:""|[\w\W]*?)*(?=",|"$))|(?<normal>(?<=,(?!")|^(?!"))[^,]*?(?=(?<!")$|(?<!"),))|(?<eol>\r\n|\n)/m';
$str = 'normal,cell,contents
cell,"with
newline",in it
cell,"with ""quoted"" text",in it
cell,with "internal" quotes,in it
single quote,"""",cell
in cell,"quotes ""followed"", by",comma';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);