re = /(?<quoted>(?<=,"|^")(?:""|[\w\W]*?)*(?=",|"$))|(?<normal>(?<=,(?!")|^(?!"))[^,]*?(?=(?<!")$|(?<!"),))|(?<eol>\r\n|\n)/m
str = 'normal,cell,contents
cell,"with
newline",in it
cell,"with ""quoted"" text",in it
cell,with "internal" quotes,in it
single quote,"""",cell
in cell,"quotes ""followed"", by",comma'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end