using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<quoted>(?<=,""|^"")(?:""|[\w\W]*?)*(?="",|""$))|(?<normal>(?<=,(?!"")|^(?!""))[^,]*?(?=(?<!"")$|(?<!""),))|(?<eol>\r\n|\n)";
string input = @"normal,cell,contents
cell,""with
newline"",in it
cell,""with ""quoted"" text"",in it
cell,with ""internal"" quotes,in it
single quote,"""",cell
in cell,""quotes ""followed"", by"",comma";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}