const regex = /^([1-9][0-9]{1,3}|10000)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9][0-9]{1,3}|10000)$', 'gm')
const str = `10
1023
235
-23
145
10000
100001
12345
23
1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}