re = /^([1-9][0-9]{1,3}|10000)$/m
str = '10
1023
235
-23
145
10000
100001
12345
23
1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end