$re = '/^([1-9][0-9]{1,3}|10000)$/m';
$str = '10
1023
235
-23
145
10000
100001
12345
23
1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);