import re
regex = re.compile(r"^([1-9][0-9]{1,3}|10000)$", flags=re.MULTILINE)
test_str = ("10\n"
"1023\n"
"235\n"
"-23\n"
"145\n"
"10000\n"
"100001 \n"
"12345\n"
"23\n"
"1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")