using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bbod\S*)|(embodi\S*)";
string input = @"Fancher: what does Eugene teach us about embodiment (for disembodied chatter bot) and intelligence? #RSA16
Faris: And in spite of turns to embodiment and sensation, little on eros of bodies #o15 #rsa16
Kerschbaum: Embodiment and embodied knowledge is always embedded with our decisions and navigations of spaces. #rsa16
#yesallwomen shows digital embodiment through storytelling. #g19 #RSA16 @RCMeg
Virtual is an extension of the corporeal body. We must pay attention to movement. To embodiment. #RSA16 #g19
#i5 #RSA16 @DrJenTalbot parrhesia assumes static notions of embodiment and power";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}