using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CODICE FISCALE\n([\s\S]+)DATA ASSUNZIONE DATA";
string input = @"CODICE FISCALE DATA DI STAMPA
01097800625
...
...
CODICE FISCALE
FRRVCN68S14E487E <------------------------I need this line
DATA ASSUNZIONE DATA";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}