// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^CODICE FISCALE\n([\s\S]+)DATA ASSUNZIONE DATA").unwrap();
let string = "CODICE FISCALE DATA DI STAMPA
01097800625
...
...
CODICE FISCALE
FRRVCN68S14E487E <------------------------I need this line
DATA ASSUNZIONE DATA";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}