$re = '/^CODICE FISCALE\n([\s\S]+)DATA ASSUNZIONE DATA/m';
$str = 'CODICE FISCALE DATA DI STAMPA
01097800625
...
...
CODICE FISCALE
FRRVCN68S14E487E <------------------------I need this line
DATA ASSUNZIONE DATA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);