import Foundation
let pattern = #"^CODICE FISCALE\n([\s\S]+)DATA ASSUNZIONE DATA"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CODICE FISCALE DATA DI STAMPA
01097800625
...
...
CODICE FISCALE
FRRVCN68S14E487E <------------------------I need this line
DATA ASSUNZIONE DATA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}