package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*([x])\s*([-+*\/])\s*(^|[ \(])\s*([-]?[0-9][\.\,\][0-9]*)\s*(^|[ \)])(?:\s*([-+*\/])\s*(^|[ \(])((?:[-])?[0-9][\.\,\][0-9]*))\s*(^|[ \)])*$`)
var str = `x* (-55) * (-0.58) `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}