re = /^\s*([x])\s*([-+*\/])\s*(^|[ \(])\s*([-]?[0-9][\.\,\][0-9]*)\s*(^|[ \)])(?:\s*([-+*\/])\s*(^|[ \(])((?:[-])?[0-9][\.\,\][0-9]*))\s*(^|[ \)])*$/
str = 'x* (-55) * (-0.58) '
# Print the match result
str.match(re) do |match|
puts match.to_s
end