const regex = /^\s*([x])\s*([-+*\/])\s*(^|[ \(])\s*([-]?[0-9][\.\,\][0-9]*)\s*(^|[ \)])(?:\s*([-+*\/])\s*(^|[ \(])((?:[-])?[0-9][\.\,\][0-9]*))\s*(^|[ \)])*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*([x])\\s*([-+*\\\/])\\s*(^|[ \\(])\\s*([-]?[0-9][\\.\\,\\][0-9]*)\\s*(^|[ \\)])(?:\\s*([-+*\\\/])\\s*(^|[ \\(])((?:[-])?[0-9][\\.\\,\\][0-9]*))\\s*(^|[ \\)])*$', '')
const str = `x* (-55) * (-0.58) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}