$re = '/^\s*([x])\s*([-+*\/])\s*(^|[ \(])\s*([-]?[0-9][\.\,\][0-9]*)\s*(^|[ \)])(?:\s*([-+*\/])\s*(^|[ \(])((?:[-])?[0-9][\.\,\][0-9]*))\s*(^|[ \)])*$/';
$str = 'x* (-55) * (-0.58) ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);