#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:SELECT\s++(?=(?:[#\w,`.]++\s++)+)|(?!^)\G\s*+,\s*+(?:`?+\s*+[#\w]++\s*+`?+\s*+\.\s*+)?+`?+\s*+)(\w++)`?+(?:\s++as\s++[^,\s]++)?+"
Local $sString = "SELECT columnA, columnB as foo, table.column8, table.column3 as foo, " & @CRLF & _
" `column7`, `column4` as foo, `table`.`columnZ`, `#__table`.`columnF` as foo FROM datable where" & @CRLF & _
"" & @CRLF & _
"Select column1, column2 From table" & @CRLF & _
"" & @CRLF & _
"select column0 from table"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")