re = /(?:SELECT\s++(?=(?:[#\w,`.]++\s++)+)|(?!^)\G\s*+,\s*+(?:`?+\s*+[#\w]++\s*+`?+\s*+\.\s*+)?+`?+\s*+)(\w++)`?+(?:\s++as\s++[^,\s]++)?+/i
str = 'SELECT columnA, columnB as foo, table.column8, table.column3 as foo,
`column7`, `column4` as foo, `table`.`columnZ`, `#__table`.`columnF` as foo FROM datable where
Select column1, column2 From table
select column0 from table'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end