const regex = new RegExp('(?:SELECT\\s++(?=(?:[#\\w,`.]++\\s++)+)|(?!^)\\G\\s*+,\\s*+(?:`?+\\s*+[#\\w]++\\s*+`?+\\s*+\\.\\s*+)?+`?+\\s*+)(\\w++)`?+(?:\\s++as\\s++[^,\\s]++)?+', 'ig')
const str = `SELECT columnA, columnB as foo, table.column8, table.column3 as foo,
\`column7\`, \`column4\` as foo, \`table\`.\`columnZ\`, \`#__table\`.\`columnF\` as foo FROM datable where
Select column1, column2 From table
select column0 from table`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}