using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{6})(?<uniqueSequence>\d{9})(?<dpbc>.{11}))";
string input = @"0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}