import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?<barCodeId>\\d{2})(?<serviceType>\\d{3})(?<mailerId>\\d{6})(?<uniqueSequence>\\d{9})(?<dpbc>.{11}))";
final String string = "0014120556239013447647712510026\n"
+ "0014120556239013447747712556417\n"
+ "0014120556239013447847712504124\n"
+ "0014120556239013447947712500422\n"
+ "0014120556239013448047712482006\n"
+ "0014120556239013448147712494417\n"
+ "0014120556239013448247712935544\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}