package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{6})(?<uniqueSequence>\d{9})(?<dpbc>.{11}))`)
var str = `0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}