using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\<\w\>)(\s*@include.*)(?=\<\/\w\>)";
string input = @" <html>
<head>
<title>hi</title>
</head>
<body>
<h1>Hi iam layout</h1>
<br>
<p>@include{""portal.shared.blook""}</p>
@require{""portal.shared.footer"":""[main]""}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}