re = /(?<=\<\w\>)(\s*@include.*)(?=\<\/\w\>)/
str = ' <html>
<head>
<title>hi</title>
</head>
<body>
<h1>Hi iam layout</h1>
<br>
<p>@include{"portal.shared.blook"}</p>
@require{"portal.shared.footer":"[main]"}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end