$re = '/(?<=\<\w\>)(\s*@include.*)(?=\<\/\w\>)/';
$str = ' <html>
<head>
<title>hi</title>
</head>
<body>
<h1>Hi iam layout</h1>
<br>
<p>@include{"portal.shared.blook"}</p>
@require{"portal.shared.footer":"[main]"}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);