import Foundation
let pattern = #"(?<=\<\w\>)(\s*@include.*)(?=\<\/\w\>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<head>
<title>hi</title>
</head>
<body>
<h1>Hi iam layout</h1>
<br>
<p>@include{"portal.shared.blook"}</p>
@require{"portal.shared.footer":"[main]"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}