package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d{1,2}\.\s{0,1}([a-zäöü]|[A-ZÄÖÜ])*(\s|\.)\d{4}`)
var str = `25.Jan.2016`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}