const regex = /\b\d{1,2}\.\s{0,1}([a-zäöü]|[A-ZÄÖÜ])*(\s|\.)\d{4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{1,2}\\.\\s{0,1}([a-zäöü]|[A-ZÄÖÜ])*(\\s|\\.)\\d{4}', '')
const str = `25.Jan.2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}