$re = '/\b\d{1,2}\.\s{0,1}([a-zäöü]|[A-ZÄÖÜ])*(\s|\.)\d{4}/';
$str = '25.Jan.2016';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);