// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{1,2}\.\s{0,1}([a-zäöü]|[A-ZÄÖÜ])*(\s|\.)\d{4}").unwrap();
let string = "25.Jan.2016";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}