# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<Lp>[^;]*);(?<Rachunek>[^;]*);(?<DataKsieg>[^;]*);(?<Kod>[^;]*);(?<Kwota>[^;]*);(?<Waluta>[^;]*);(?<Opis>.*);(?<DataWaluty>.*)$"
test_str = "2;XXXXXXXXXXXXXXXXXXXXXXXXXX;05.01.2016 00:00;911;7,47;PLN;911 Transakcja Collect; ID IPH: VVVVVVVVVVVVVV; z rach.: AAAAAAAAAAAAAAAAAAAAAAAAAA; od: BANK POCZTOWY S.A. w imieniu XXXXX XXX XXX _; tyt.: XX XX Km XX/XX VI Nc-e 1 XXX/13 XXXX KsP XXX/15 N a 30-12-2015 Na kwote 7 47 AAAAAAAAAAAAAAAAAAAAAAAAAA; TNR: xxxxxxxxxxxxx.xxxxxxx;05.01.16\""
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.