re = /^(?<Lp>[^;]*);(?<Rachunek>[^;]*);(?<DataKsieg>[^;]*);(?<Kod>[^;]*);(?<Kwota>[^;]*);(?<Waluta>[^;]*);(?<Opis>.*);(?<DataWaluty>.*)$/i
str = '2;XXXXXXXXXXXXXXXXXXXXXXXXXX;05.01.2016 00:00;911;7,47;PLN;911 Transakcja Collect; ID IPH: VVVVVVVVVVVVVV; z rach.: AAAAAAAAAAAAAAAAAAAAAAAAAA; od: BANK POCZTOWY S.A. w imieniu XXXXX XXX XXX _; tyt.: XX XX Km XX/XX VI Nc-e 1 XXX/13 XXXX KsP XXX/15 N a 30-12-2015 Na kwote 7 47 AAAAAAAAAAAAAAAAAAAAAAAAAA; TNR: xxxxxxxxxxxxx.xxxxxxx;05.01.16"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end