// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^(?<Lp>[^;]*);(?<Rachunek>[^;]*);(?<DataKsieg>[^;]*);(?<Kod>[^;]*);(?<Kwota>[^;]*);(?<Waluta>[^;]*);(?<Opis>.*);(?<DataWaluty>.*)$").unwrap();
let string = "2;XXXXXXXXXXXXXXXXXXXXXXXXXX;05.01.2016 00:00;911;7,47;PLN;911 Transakcja Collect; ID IPH: VVVVVVVVVVVVVV; z rach.: AAAAAAAAAAAAAAAAAAAAAAAAAA; od: BANK POCZTOWY S.A. w imieniu XXXXX XXX XXX _; tyt.: XX XX Km XX/XX VI Nc-e 1 XXX/13 XXXX KsP XXX/15 N a 30-12-2015 Na kwote 7 47 AAAAAAAAAAAAAAAAAAAAAAAAAA; TNR: xxxxxxxxxxxxx.xxxxxxx;05.01.16\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}