using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!(?:[^\S\r\n]*\w){21})\w+(?:\s+\w+){0,2}(?=$|[\r\n])";
string input = @"The early bird catches the worm
Here we have a supercalifragilisticexpialidocious sentence";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}