re = /\b(?!(?:[^\S\r\n]*\w){21})\w+(?:\s+\w+){0,2}(?=$|[\r\n])/
str = 'The early bird catches the worm
Here we have a supercalifragilisticexpialidocious sentence'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end