import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!(?:[^\\S\\r\\n]*\\w){21})\\w+(?:\\s+\\w+){0,2}(?=$|[\\r\\n])";
final String string = "The early bird catches the worm\n"
+ "Here we have a supercalifragilisticexpialidocious sentence";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}