using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/reverseproxy\/([^/]*)(.*)";
string input = @"http://localhost:8080/reverseproxy/maps.google.com/maps?q=lon,lat";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}