package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/reverseproxy\/([^/]*)(.*)`)
var str = `http://localhost:8080/reverseproxy/maps.google.com/maps?q=lon,lat`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}