$re = '/\/reverseproxy\/([^/]*)(.*)/';
$str = 'http://localhost:8080/reverseproxy/maps.google.com/maps?q=lon,lat';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);