re = /\/reverseproxy\/([^\/]*)(.*)/
str = 'http://localhost:8080/reverseproxy/maps.google.com/maps?q=lon,lat'
# Print the match result
str.match(re) do |match|
puts match.to_s
end