import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(---(.|\\n)*---\\n)(.*(.|\\n)*)";
final String string = "---\n"
+ "Title: \n"
+ "Date: 2020-04-05\n"
+ "Tags: [log]\n"
+ "---\n\n"
+ "Bla Bla bla bla\n"
+ "bla bla bla bla\n"
+ "Bla Bla bla bla\n"
+ "bla bla bla bla\n"
+ "Bla Bla bla bla\n"
+ "bla bla bla bla\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}