re = /(---(.|\n)*---\n)(.*(.|\n)*)/
str = '---
Title:
Date: 2020-04-05
Tags: [log]
---
Bla Bla bla bla
bla bla bla bla
Bla Bla bla bla
bla bla bla bla
Bla Bla bla bla
bla bla bla bla
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end