$re = '/(---(.|\n)*---\n)(.*(.|\n)*)/';
$str = '---
Title:
Date: 2020-04-05
Tags: [log]
---
Bla Bla bla bla
bla bla bla bla
Bla Bla bla bla
bla bla bla bla
Bla Bla bla bla
bla bla bla bla
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);