import re
regex = re.compile(r"(---(.|\n)*---\n)(.*(.|\n)*)")
test_str = ("---\n"
"Title: \n"
"Date: 2020-04-05\n"
"Tags: [log]\n"
"---\n\n"
"Bla Bla bla bla\n"
"bla bla bla bla\n"
"Bla Bla bla bla\n"
"bla bla bla bla\n"
"Bla Bla bla bla\n"
"bla bla bla bla\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")